wamp2.2升级php5.3.5到php5.4.45过程中遇到的问题汇总

wamp2.2升级php5.3.5到php5.4.45过程中遇到的问题汇总

昨天捣鼓WordPress中的统计插件“WP Statistics”,安装完才发现需要至少php5.4。因为服务器上用的是wamp2.2,默认带的是php5.3.5。所以决定升级。

今天一开始先下载了wamp2.5,里面是php5.5.12的,肯定够用了。在自己电脑上wamp2.2的基础上,直接安装了wamp2.5,安装完无法打开wamp。具体的原因也不追究了,还是想着只升级个php版本就好了。

一开始直接把wamp2.5里面的php5.5.12打包放到服务器上,按照网友的文章(参考:http://www.cnblogs.com/yuwensong/p/3897878.html),wamp重启后是黄色图标。猜想是vc11环境没有安装,又安装了vc11,还是不行,php官网下载了5.6.30也还是同样的问题。

后来看了另一个网友的文章(参考:http://blog.csdn.net/xiongsha/article/details/51789368),才发现,wamp2.2最高只能支持php5.4,于是就重新从官网下载了5.4.45版本。因为5.4.45是vc9的,所以还需要安装vc9

还是按照上面网友的方法升级,这次wamp能启动了,但是curl模块无法加载。

没办法,继续寻找办法,终于看到这位网友的文章(参考:http://blog.csdn.net/qq_27606233/article/details/48153571),把libssh2.dll复制到\Apache2.2.17\bin下,这次启动之后,终于一切正常了。注意,文章中说到的复制几个dll到 system32 目录下,这一步可以忽略掉

 

总结:升级任何环境,不是版本越高越好,要注意和其他环境之间的版本需求关系。把这个过程记录下来,希望后来者能少走点弯路。

发表评论

电子邮件地址不会被公开。 必填项已用*标注